Monday, August 10, 2015

MPLS and ATM


Introduction:

This lab introduces you how to implement a MPLS and ATM network from scratch. To deeply understand this lab, you need a solid understanding of Layer 2, 3 switching and  routing. This lab also provides some basic routing protocols as RIPv2, BGP (iBGP,eBGP) and how MPLS works in ATM environment. More importantly, you'll learn how to configure, verify and troubleshoot cell-mode  MPLS in ATM network.


Overview:

- There are 2 modes for MPLS running in ATM environement.
  • Frame mode: When MPLS is set up on a serial interface, it runs in frame mode. Or, if a ATM sub-interface (PE1's a1/0 sub-interface, PE2's a1/0 sub-interface) is set up as PPP, when MPLS is enabled it will run in frame mode.
  • Cell mode: If a ATM sub-interface (PE1's a1/0 interface, PE2's a1/0 interface) is set up as mpls, when MPLS is enabled it will run in cell mode.
 - Frame-mode MPLS means that label distribution will be independent control with unsoliciated while cell-mode MPLS means label distribution will be ordered control with downstream-on-demand. For independent control with unsoliciated definitions, go to Frame-Mode MPLS. Assume that traffic flow from PE1 to PE2:
  • Ordered control occurs when an upstream LSR must wait on a label to be received from its downstream LSR. In this lab, PE1 waits for the label from ATM1, ATM1 waits for ATM2, ATM2 waits for PE2.
  • Downstream-on-demand occurs when an upstream LSR, using the Label Request message, requests a label from its downstream neighbor. In this lab, PE1 sends label request to ATM1, ATM1 sends label request to ATM2, ATM2 sends label request to PE2 and then the new label (VPI/VCI pair) is created on PE2. It is sent to ATM2. ATM2 creates a new label and sends this label to ATM1 and so on. 
 - In frame-mode MPLS, an unlabeled packet enters the network, and the ingress edge-LSR applies a label that is used to label-switch the packet through the service provider network, ultimately delivering it to the egress edge-LSR.
- In cell-mode, an unlabeled packet enters the network, and the ingress ATM edge-LSR uses the VPI/VCI mappings as the label. Each ATM-LSR in the LSP through the service provider network switches the packet based solely on the VPI/VCI values. Remember, in cell-mode MPLS, labels equal VPI/VCI pair values. In this lab, only cell-mode MPLS in ATM environment is configured and discussed.

Requirements:

1. Customer sites:
  • CE1 and CE2 (Non-MPLS-enabled routers): BGP.
  • H/W: CE1 and CE2 are Cisco Routers c3745.
2.  Service Provider sites: 
  • PE1, PE2 (ATM Edge-LSRs is edge LSRs with at least one ATM interface): RIPv2, BGP, MPLS: a1/0.2 sub-interface.
  • ATM1, ATM2 (LC ATM or ATM-LSRs): RIPv2, MPLS: a1/0.1, a2/0.1 sub-interface.
  • H/W: PE1, ATM1, ATM2 and PE2 are Cisco Routers c7200.
Configuration

1. Customer sites:

- Customers including CE1 and CE2 are connected each other via service provider network.

- On CE1 router:

CE1#show running-config

Building configuration...

Current configuration : 2477 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$XlhS$3oqxht/njX9deOdms7qxp/
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 10.1.0.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 description ***Link to PE1 router***
 ip address 10.2.0.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/4
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/5
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet3/0
!
interface FastEthernet3/1
!
interface FastEthernet3/2
!
interface FastEthernet3/3
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!
interface FastEthernet3/12
!
interface FastEthernet3/13
!
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface Vlan1
 no ip address
!
router bgp 65001
 no synchronization
 bgp log-neighbor-changes
 redistribute connected
 neighbor 10.2.0.1 remote-as 65000
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password console
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 password telnet
 login
!
!
end

- CE2 router is configured similarly.

2. Service provider sites:

 a. ATM edge LSRs (PE1,PE2 ):

-  On PE1 router:

PE1#show running-config

Building configuration...

Current configuration : 2166 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$QOwM$6LFM02vqm6zRTKi0JDIXm0
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface ATM1/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM1/0.2 mpls
 description ***Link to ATM1***
 ip address 192.168.1.13 255.255.255.252
 mpls ip
 pvc 0/200
  encapsulation aal5snap
 !
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial4/0
 description ***Link to CE1 router***
 ip address 10.2.0.1 255.255.255.252
 serial restart-delay 0
 no fair-queue
!
interface Serial4/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/4
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/5
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/6
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/7
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.2.0.2 remote-as 65001
 neighbor 192.168.1.2 remote-as 65000
 neighbor 192.168.1.2 update-source Loopback0
 neighbor 192.168.1.2 next-hop-self
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password console
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 password telnet
 login
!
!
end

- PE2 router is configured similarly.

b. ATM LSRs (ATM1, ATM2):

- On ATM1 router:

ATM1#show running-config

Building configuration...

Current configuration : 2011 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ATM1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$x9Q8$YvWb44romN0JTC4r/9RGr.
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 192.168.1.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface ATM1/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM1/0.1 mpls
 description ***Link to PE1 router***
 ip address 192.168.1.14 255.255.255.252
 mpls ip
 pvc 0/400
  encapsulation aal5snap
 !
!
interface ATM2/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM2/0.1 mpls
 description ***Link to ATM2****
 ip address 192.168.1.21 255.255.255.252
 mpls ip
 pvc 0/500
  encapsulation aal5snap
 !
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial4/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/4
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/5
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/6
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/7
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password console
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 password telnet
 login
!
!
end

- ATM2 is configured similarly.

Verification:

 Check the connection between CE1 router and CE2 router.

CE1#ping 10.4.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.4.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 532/612/692 ms

CE1#telnet 10.4.0.1

Trying 10.4.0.1 ... Open


User Access Verification

Password:
CE2>

CE2#ping 10.1.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 456/617/836 ms

CE2#telnet 10.1.0.1

Trying 10.1.0.1 ... Open


User Access Verification

Password:
CE1>

Troubleshooting:

CE1#trace 10.4.0.1

Type escape sequence to abort.
Tracing the route to 10.4.0.1

  1 10.2.0.1 72 msec 200 msec 264 msec
  2 192.168.1.14 [MPLS: Label 19 Exp 0] 532 msec 528 msec 620 msec
  3 192.168.1.22 [MPLS: Label 18 Exp 0] 528 msec 460 msec 596 msec
  4 192.168.1.17 [MPLS: Label 0 Exp 0] 568 msec 464 msec 456 msec
  5 10.3.0.2 [AS 65002] 648 msec 720 msec 752 msec

CE1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.2.0.0/30 is directly connected, Serial0/0
B       10.3.0.0/30 [20/0] via 10.2.0.1, 01:26:01
C       10.1.0.1/32 is directly connected, Loopback0
B       10.4.0.1/32 [20/0] via 10.2.0.1, 01:26:01


- There are 5 hops for a packet traversing from CE1 to CE2. The path from CE1 to CE2 is as follows:

1 10.2.0.1 72 msec 200 msec 264 msec--> This is PE1 router which is directly connected to CE1's s0/0. So, the unlabeled packet handed from CE1 to PE1 router. 

- Check the PE1's routing table and forwarding table:

PE1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.2.0.0/30 is directly connected, Serial4/0
B       10.3.0.0/30 [200/0] via 192.168.1.2, 02:11:19
B       10.1.0.1/32 [20/0] via 10.2.0.2, 02:11:19
B       10.4.0.1/32 [200/0] via 192.168.1.2, 02:11:19
     192.168.1.0/24 is variably subnetted, 7 subnets, 2 masks
C       192.168.1.12/30 is directly connected, ATM1/0.2
C       192.168.1.1/32 is directly connected, Loopback0
R       192.168.1.3/32 [120/1] via 192.168.1.14, 00:00:08, ATM1/0.2
R       192.168.1.2/32 [120/3] via 192.168.1.14, 00:00:08, ATM1/0.2
R       192.168.1.4/32 [120/2] via 192.168.1.14, 00:00:08, ATM1/0.2
R       192.168.1.16/30 [120/2] via 192.168.1.14, 00:00:08, ATM1/0.2
R       192.168.1.20/30 [120/1] via 192.168.1.14, 00:00:08, ATM1/0.2
PE1#show mpls forwarding-table

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     1/34        192.168.1.3/32    0          AT1/0.2    point2point
17     1/35        192.168.1.4/32    0          AT1/0.2    point2point
18     1/36        192.168.1.16/30   0          AT1/0.2    point2point
19     1/37        192.168.1.20/30   0          AT1/0.2    point2point
20     1/33        192.168.1.2/32    0          AT1/0.2    point2point

From the routing table, there is a BGP route to get the packet from PE2 to CE2 via 192.168.1.2 (PE1's loopback interface). How does the PE1 router get the packet to the PE2 POP router?

Well, an IP packet enters the network at the PE1 router. The PE1 router performs a lookup, and the mapping of label to the VPI/VCI value is identified. The IP packet is broken up, or segmented, into ATM cells, and the VPI/VCI value is applied to each cell as it is sent to ATM1. If the ATM1 uses the same label for cells traveling to a common destination, the receiving device (downstream device) does not know how to reassemble the cells into packets if there are 2 or more ATM Edge LSRs send packets to ATM1 at the same time . How can this problem be fixed? By using multiple labels for each flow. When these cells are received by an end device that needs to reassemble the cells back into packets, it’s easy to tell the cells apart by their labels. However, There is one drawback to this solution. ATM 1 uses many labels. For each flow, ATM 1 sends a downstream-on-demand–style request to its down-stream ATM-LSR, requesting labels for each flow. VC merge fixes cell interleaving and reduces the number of labels required by buffering cell flows and forwarding them in a serialized fashion. The cell flow from ATM Edge LSR2 is buffered, while the flow of cells from ATM Edge LSR1 is sent out the outbound interface. When the cell flow from ATM Edge LSR1 is complete, the cell flow from ATM Edge LSR2 is sent out the outbound interface. A downstream device needing to reassemble the cells receives each flow in order. VC merge in enabled on Cisco Router by default.
  Now, you just need to remember that in ATM network, the label is mapped to the VPI/VCI values. In essence, the label replaces the VPI/VCI value. The process of an unlabeled IP packet entering the network, having a label imposed, and then being label-switched has not changed. The only thing that’s different is that in ATM, the label is the VPI/VCI value.

  Indeed, from PE1's forwarding table, PE1 switches the packet to outgoing sub-interface AT1/0.2 with outbound VC 1/33 to ATM1/0.2 (192.168.1.14).

2 192.168.1.14 [MPLS: Label 19 Exp 0] 532 msec 528 msec 620 msec --> The packet is switched from PE1 to ATM1's a1/0 interface (192.168.1.14). Let's take a look on the ATM1's routing table and forwarding table:

ATM1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 7 subnets, 2 masks
C       192.168.1.12/30 is directly connected, ATM1/0.1
R       192.168.1.1/32 [120/1] via 192.168.1.13, 00:00:07, ATM1/0.1
C       192.168.1.3/32 is directly connected, Loopback0
R       192.168.1.2/32 [120/2] via 192.168.1.22, 00:00:01, ATM2/0.1
R       192.168.1.4/32 [120/1] via 192.168.1.22, 00:00:01, ATM2/0.1
R       192.168.1.16/30 [120/1] via 192.168.1.22, 00:00:01, ATM2/0.1
C       192.168.1.20/30 is directly connected, ATM2/0.1

ATM1#show mpls forwarding-table

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     1/34        192.168.1.4/32    0          AT2/0.1    point2point
17     1/35        192.168.1.16/30   1584       AT2/0.1    point2point
18     1/33        192.168.1.1/32    55724      AT1/0.1    point2point
19     1/33        192.168.1.2/32    51327      AT2/0.1    point2point

Obviously, when the labeled packet of 1/33 arrives at ATM1,  ATM1 switches the packet to outgoing sub-interface AT2/0.1 with outbound VC 1/33 to 192.168.1.22 (ATM2).

3 192.168.1.22 [MPLS: Label 18 Exp 0] 528 msec 460 msec 596 msec---> The packet is switched from ATM1 to ATM2 (192.168.1.22). Let's take a look on the ATM2's routing table and forwarding table:

ATM2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 7 subnets, 2 masks
R       192.168.1.12/30 [120/1] via 192.168.1.21, 00:00:24, ATM2/0.1
R       192.168.1.1/32 [120/2] via 192.168.1.21, 00:00:24, ATM2/0.1
R       192.168.1.3/32 [120/1] via 192.168.1.21, 00:00:24, ATM2/0.1
R       192.168.1.2/32 [120/1] via 192.168.1.17, 00:00:02, ATM1/0.1
C       192.168.1.4/32 is directly connected, Loopback0
C       192.168.1.16/30 is directly connected, ATM1/0.1
C       192.168.1.20/30 is directly connected, ATM2/0.1

ATM2#show mpls forwarding-table

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     1/33        192.168.1.3/32    0          AT2/0.1    point2point
17     1/34        192.168.1.12/30   1584       AT2/0.1    point2point
18     1/33        192.168.1.2/32    57249      AT1/0.1    point2point
19     1/35        192.168.1.1/32    60335      AT2/0.1    point2point

Obviously, when the labeled packet of 1/33 arrives at ATM2,  ATM2 switches the packet to outgoing sub-interface AT1/0.1 with outbound VC 1/33 to 192.168.1.17 (PE2).

4 192.168.1.17 [MPLS: Label 0 Exp 0] 568 msec 464 msec 456 msec--> The packet is switched from ATM2 to PE2 (192.168.1.17). Let's take a look on the PE2's routing table and forwarding table:

PE2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B       10.2.0.0/30 [200/0] via 192.168.1.1, 05:02:44
C       10.3.0.0/30 is directly connected, Serial4/0
B       10.1.0.1/32 [200/0] via 192.168.1.1, 05:02:44
B       10.4.0.1/32 [20/0] via 10.3.0.2, 05:02:45
     192.168.1.0/24 is variably subnetted, 7 subnets, 2 masks
R       192.168.1.12/30 [120/2] via 192.168.1.18, 00:00:10, ATM1/0.2
R       192.168.1.1/32 [120/3] via 192.168.1.18, 00:00:10, ATM1/0.2
R       192.168.1.3/32 [120/2] via 192.168.1.18, 00:00:10, ATM1/0.2
C       192.168.1.2/32 is directly connected, Loopback0
R       192.168.1.4/32 [120/1] via 192.168.1.18, 00:00:10, ATM1/0.2
C       192.168.1.16/30 is directly connected, ATM1/0.2
R       192.168.1.20/30 [120/1] via 192.168.1.18, 00:00:10, ATM1/0.2

PE2#show mpls forwarding-table

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     1/34        192.168.1.4/32    0          AT1/0.2    point2point
17     1/36        192.168.1.20/30   0          AT1/0.2    point2point
18     1/33        192.168.1.3/32    0          AT1/0.2    point2point
19     1/35        192.168.1.12/30   0          AT1/0.2    point2point
20     1/37        192.168.1.1/32    0          AT1/0.2    point2point

There is a BGP route to get 10.4.0.1 via 10.3.0.2 (CE2's s0/0). In this case, the packet is routed to destination based on routing protocol BGP.

5 10.3.0.2 [AS 65002] 648 msec 720 msec 752 msec--> Indeed, the packet is handed to 10.3.0.2 that is CE2's s0/0.

Well-done! The journey for the packet taking from CE1 to CE2 is completed.

Now, your turn to analize the path from CE2 to CE1.

CE2#trace 10.1.0.1

Type escape sequence to abort.
Tracing the route to 10.1.0.1

  1 10.3.0.1 120 msec 136 msec 212 msec
  2 192.168.1.18 [MPLS: Label 17 Exp 0] 572 msec 608 msec 460 msec
  3 192.168.1.21 [MPLS: Label 16 Exp 0] 464 msec 392 msec 528 msec
  4 192.168.1.13 [MPLS: Label 0 Exp 0] 520 msec 536 msec 484 msec
  5 10.2.0.2 [AS 65001] 588 msec 524 msec 588 msec

Conclusions:

In this lab, you learned that there are 2 modes for MPLS in ATM environment: frame mode and cell mode. Frame mode uses independent control with unsoliciated for label binding while cell mode uses ordered control with downstream-on-demand. You also learned the difference in operation between frame mode and cell mode as well as the importance of VC merge. In addition, you are also familiar with the configuration, verification and troubleshooting  cell mode MPLS in ATM network.

No comments:

Post a Comment